ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

Manual Uninstall of EEM

book

Article ID: 41403

calendar_today

Updated On:

Products

CA Workload Automation AE - Business Agents (AutoSys) CA Workload Automation AE - Scheduler (AutoSys) Workload Automation Agent

Issue/Introduction

 

Problem: 

   While running the uninstall of EEM, it complains about the applications being configured and does not let the EEM to uninstall to complete successful.

# /opt/CA/SharedComponents/EmbeddedEntitlementsManager/uninstall/eiamuninstall

===============================================================================

CA Embedded Entitlements Manager                 (created with InstallAnywhere)

-------------------------------------------------------------------------------

Preparing CONSOLE Mode Uninstallation...

===============================================================================

===============================================================================

Uninstall CA Embedded Entitlements Manager

-------------------------------------------

About to uninstall...

CA Embedded Entitlements Manager

This will remove features installed by InstallAnywhere.  It will not remove

files and folders created after the installation.

PRESS <ENTER> TO CONTINUE:

=========================================================

Information : Registered Application Check

=========================================================

Applications [WCC0004, WorkloadAutomationAE] are in use. EEM uninstaller can

not continue until all applications are unregistered

Cause: 

EEM would not let the uninstall proceed with applications still being registered. 

Environment:

All supported EEM platforms

Resolution: 

1) Login to EEM UI [Application: Global] as the EEM Administrator (EiamAdmin)

2) Click on Configure > Applications > Select the application names then click on Un-register.

Important!: Before you unregister the applications it is mandatory to take a backup as it would cause the permanent loss of security policies. Please follow the links provided under Additional Information to export the WAAE and WCC Security policies.

3) Then Try the uninstall, again using './eiamuninstall' and it should run the  uninstall to Complete.

Note: In case that does not go success; Please follow the below process to force uninstall EEM.

1)  Execute the binary "eiamuninstall" with the parameter  "-DFORCE_UNINSTALL=true" as shown below:

     # /opt/CA/SharedComponents/EmbeddedEntitlementsManager/uninstall/eiamuninstall -DFORCE_UNINSTALL=true

2) "PRESS <ENTER> TO CONTINUE" >> This will lead to the successful completion of the EEM uninstallation

[Uninstall Complete].

 

Additional Information:

   Links:  

Export the WAAE Security Policies to an XML File

Export the WCC Security Policies to an XML File 

Uninstall EEM

Supported Operating Systems

Environment

Release: ATSYHA99000-11.3.6-Workload Automation AE-High Availability Option
Component: