GSS 3.3.13 - XML generated for Sysprep answer file and during computer export is corrupted
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GSS 3.3.13 - XML generated for Sysprep answer file and during computer export is corrupted

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Article ID: 413992

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Updated On:

Products

Ghost Solution Suite

Issue/Introduction

Post imaging boot issues are observed on Windows 10 and 11 machines after capturing a Sysprep image with Ghost Solution Suite 3.3.13

After the first attempted boot to Windows after the capture with Sysprep is complete, the following error is observed on the 'Getting ready' screen:

Windows could not parse or process unattend answer file [C:\WINDOWS\Panther\unattend.xml] for pass [specialize]. The answer file is invalid.

If 'OK' is selected, the machine reboots and the following error is then observed:

The computer restarted unexpectedly or encountered an unexpected error. Windows installation cannot proceed. To install Windows, click "OK" to restart the computer, and then restart the installation.

Environment

GSS 3.3.13

Cause

XML files generated by GSS 3.3.13 may set incorrect attribute values. This results in two main issues:

1 - The Sysprep file created during an imaging task using the Sysprep option does not work. It contains corrupted sections, such as:

<component xmlns="" name="name" processorArchitecture="processorArchitecture" publicKeyToken="publicKeyToken" language="language" versionScope="versionScope" xmlns:wcm="xmlns:wcm" xmlns:xsi="xmlns:xsi">

2 -  Computers exported into an XML file also have corrupted XML sections, similar to the following; however, these files still appear to import and function properly:
<computers ver="ver" xmlns:xsi="xmlns:xsi" xsi:noNamespaceSchemaLocation="xsi:noNamespaceSchemaLocation">

As a result, the system is in a reboot loop following imaging.

Resolution

A fixed drop-in aexengine executable (for Sysprep issue) and express.exe (for computer export issue) is attached to this article. Proceed with the steps below to address both issues described above:

  1. Download the attached ZIP file and extract to the Ghost Solution Suite server.

  2. Stop the Altiris eXpress service on the GSS server and close the console (may also need to check in Windows Task Manager that no other instances of eXpress.exe are running in case if Remote Consoles are launched)

  3. Replace files in default GSS installation eXpress share (by default in ".\Altiris\eXpress\Deployment Server")

Attachments

EM-91810 - XML generated for Sysprep and for computer export.zip get_app