GSS 3.3.13 - XML generated for Sysprep answer file and during computer export is corrupted
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GSS 3.3.13 - XML generated for Sysprep answer file and during computer export is corrupted

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Article ID: 413992

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Updated On:

Products

Ghost Solution Suite

Issue/Introduction

You might encounter an unexpected imaging task failure when using sysprep option for the imaging.

Environment

GSS 3.3.13

Cause

XML files generated by GSS 3.3.13 may set incorrect attribute values. This results in two main issues:

1 - The Sysprep file created during an imaging task using the Sysprep option does not work. It contains corrupted sections, such as:

<component xmlns="" name="name" processorArchitecture="processorArchitecture" publicKeyToken="publicKeyToken" language="language" versionScope="versionScope" xmlns:wcm="xmlns:wcm" xmlns:xsi="xmlns:xsi">

2 -  Computers exported into an XML file also have corrupted XML sections, similar to the following; however, these files still appear to import and function properly:
<computers ver="ver" xmlns:xsi="xmlns:xsi" xsi:noNamespaceSchemaLocation="xsi:noNamespaceSchemaLocation">

Resolution

Attached is drop-in aexengine executable (for sysprep issue) and express.exe(for export computers issue).

Download attached ZIP file and extract.

Stop Altiris eXpress service and close the console (might need to check in Windows Task Manager that no other instances of eXpress.exe are running in case if Remote Consoles are launched).

Replace files in default GSS installation folder (by default in ".\Altiris\eXpress\Deployment Server").

Attachments

EM-91810 - XML generated for Sysprep and for computer export.zip get_app