Firmware information is not available because there is no Hardware Support Manager configured for the cluster.
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Firmware information is not available because there is no Hardware Support Manager configured for the cluster.

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Article ID: 413926

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Updated On:

Products

VMware vSphere Foundation

Issue/Introduction

In a VMware vSphere Foundation environment, after configuring a vSAN cluster with an ESXi image,

  • You see the warning, "Firmware information is not available because there is no Hardware Support Manager configured for the cluster. Firmware compatibility must be verified manually"
  • Host is marked as not compliant. Warning is, "Host is out of compliance with the image"
  • Firmware version is empty under Driver and Firmware in the Cluster's image

Environment

VMware vSphere Foundation 9.0

VMware vCenter 9.0

Cause

Hardware Support Manager is not configured correctly and a Firmware and Driver addon has not been added to the Cluster Image.

vCenter Server is unable to query the current firmware version from the Hardware Support Manager.

Resolution

Ensure that the Hardware Support Manager is configured correctly.

Edit the image and add a Vendor Firmware and Driver addon from the Hardware Support Manager.

For eg. 

With Dell OMEVV Hardware Support Manager ensure,

  1. Host Connection Profile is associated to the host for discovery and inventory. 
  2. A valid OMIVV or DRAC Advanced+ license for OMEVV.
  3. Create a firmware repository profile, either with the Dell online Catalog (for non-VSAN) or offline catalog (presented using a network share).

For more information, see, Dell OpenManage : How to Resolve Cluster Profile Not Created or Cluster Not Associated to a Cluster Profile Message in OMIVV and OMEVV.

Additional Information