Getting following error "An error occurred while fetching identity providers. Please try again later. If the problem persists, contact your administrator" when logging in with domain users on vCenter Server 9.0
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Getting following error "An error occurred while fetching identity providers. Please try again later. If the problem persists, contact your administrator" when logging in with domain users on vCenter Server 9.0

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Article ID: 413870

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • Unable to login to vCenter Server using domain account credentials and the following error is received on the UI: 
    An error occurred while fetching identity providers. Please try again later. If the problem persists, contact your administrator
  • The embedded identity source does not populate correctly in vCenter UI under Administration > Configuration > Identity Provider

Environment

VMware vCenter Server 9.0

Cause

The issue happens because of vmware-trustmanagement service down due to a race condition during service startup sequence. 

The same can be confirmed by running the following command on the vCenter Server's SSH: 

service-control --status --all

Resolution

Broadcom is aware of this issue and working towards a fix in a future release.

  1. To workaround the issue, manually start the vmware-trustmanagement service with the help of following command on vCenter Server's SSH : 
    service-control --start vmware-trustmanagement
  2. Reload the Identity Provider page in the vCenter Server browser interface. It should now display the embedded identity sources correctly, and Active Directory users should be able to authenticate successfully. 

Additional Information

This can occur 90 days after the vCenter Server is deployed. The issue comes from a race condition between trustmanagement and sts when all the services are started at once.
Once the trust management service is started again, the problem will not occur again for at least another 90 days.