vLCM fails to update Hosts and shows error "Health check fails to retrieve data about service Workload Management Platform"
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vLCM fails to update Hosts and shows error "Health check fails to retrieve data about service Workload Management Platform"

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Article ID: 413867

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Updated On:

Products

VMware vCenter Server VMware vSphere ESX 8.x

Issue/Introduction

  • Upgrade is attempted from ESX 8.0 U3e build 24674464 to ESX 8.0 U3g build 24859861 using vLCM
  • When running the pre-check, the pre-check shows below error-
    Health check fails to retrieve data about service 'Workload Management Platform' on 'domain-####'. Verify that the service 'Workload Management Platform' is running and try again.
  • vmware-vum-server.log on vCenter showed the error while upgrading:

    var/log/vmware/vmware-updatemgr/vum-server/vmware-vum-server-34.log:115481:2025-09-12T15:14:22.942-05:00 info vmware-vum-server [Originator@#### sub=Telemetry] [TelemetryManager ###] Sending telemetry "parentTaskId":"","errorMessageId":"com.vmware.vcIntegrity.lifecycle.health.internal.external_provider.call_fault","errorMessage":"Health check fails to retrieve data about service 'Workload Management Platform'. Verify that the service 'Workload Management Platform' is running and try again."

Environment

  • vCenter Version: 8.0.3
  • ESXi 8.0 Update 3

Cause

WCP service on vCenter Server is not in a healthy state.

Resolution

  1. Apply the resolution section of this KB:
    Remediation of host fails with health check failure
    If the error persists even after restarting the WCP service as described in the above knowledge base article, please proceed to Step 2.

  2. Run though the script as per below KB and ensure that the vpxd-extension user isn't missing any SSO group permissions.
    Fixing missing SSO Group Memberships for vSphere Solution Users with the solution_users_fixer script
    Then try the upgrade pre-check.
    If it still fails , then proceed to step 3.

  3. You can try this step ONLY if you are NOT using VKS/TKGS/Tanzu in this environment.
    If you are Not using VKS/TKGS/Tanzu, then please disable the health check for wcp to allow the patch.
    You can do this by editing the vci-integrity.xml file.
    Here is how to do it:

    SSH into the vCenter Server using root credentials.
    Stop the vLCM Update Manager service:
    service-control --stop updatemgr
    Back up the vLCM configuration file (vci-integrity.xml):
    cp /usr/lib/vmware-updatemgr/bin/vci-integrity.xml /usr/lib/vmware-updatemgr/bin/vci-integrity.bak
    Edit the configuration file:
    vi /usr/lib/vmware-updatemgr/bin/vci-integrity.xml
     
    <EhpConfig>
        <ExternalProviders>
          <eam>
            <enabled>true</enabled>
          </eam>
          <nsxt_rest>
            <enabled>true</enabled>
          </nsxt_rest>
          <pod>
            <enabled>true</enabled>
          </pod>
          <vpxd>
            <enabled>true</enabled>
          </vpxd>
          <wcp>
            <enabled>true</enabled> <<<<<<<<<<<<<<
          </wcp>
        </ExternalProviders>

    Please change it to false :  <enabled>false</enabled>
    Save the file and restart the Update Manager service:
    service-control --start updatemgr
    Once the service is restarted, log in to vCenter and reattempt the pre-check and upgrade. 

    When all the upgrades are successfully completed, please re-enable the health check for wcp.