After increasing the disk size of an application hosted on TAS, it 'CRASHED' with 'Codependent step exited. Exit status 137".
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After increasing the disk size of an application hosted on TAS, it 'CRASHED' with 'Codependent step exited. Exit status 137".

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Article ID: 413808

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Updated On:

Products

VMware Tanzu Application Service

Issue/Introduction

You have increased the size of your application via the application manifest file and the Operations Manager UI. You have also increased the space/org quota for disk sizing per application but are still hitting an error similar to below:
 
[API/2] [OUT]Process has crashed with type: "web"
[API/2] [OUT] App instance exited with guid <APP-GUID-EXAMPLE> payload: {"instance"=>"<INSTANCE-EXAMPLE>", "index"=>0, "cell_id"=>"<CELL-ID-EXAMPLE>", "reason"=>"CRASHED", "exit_description"=>"Codependent step exited", "crash_count"=>1, "crash_timestamp"=>12345654321, "version"=>"<VERSION-EXAMPLE>"}
[PROXY/0] [OUT] Exit status 137

You are using Scheduler service for the application.

Cause

There is a task (added with the Scheduler service that is bound to the application) that does not have adequate disk space allotted to properly execute/succeed. See how to determine if you hit this issue by following the steps outlined below, in the 'Resolution' field.When the user created the task the app had 1gb disk. When you increased the app to 2gb the task stayed with just 1gb.

Resolution

First, confirm the issue by running command: 'cf tasks <APP_NAME>'.  Then search this output to see if any tasks are 'FAILED', as illustrated below. If yes, move to next item.

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Second, check appsmanager UI to see if Scheduler service is bound to the application. See official docs for more info on this topic: Managing Apps.

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Lastly, create and schedule the Task/job from scratch again from Appsman UI. This will allow the new/updated memory settings to be applied and avoid any issue.