SDDC Password Manager shows blank status for NSX Edge Nodes
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SDDC Password Manager shows blank status for NSX Edge Nodes

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Article ID: 413800

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Updated On:

Products

VMware SDDC Manager VMware Cloud Foundation

Issue/Introduction

A blank status for NSX Edge nodes is shown in password manager.

Environment

  • VMware Cloud Foundation 4.x
  • VMware Cloud Foundation 5.x

Cause

It is commonly caused due to following reasons;

  • Expired password
  • Out-of-band password changes. 

Resolution

To resolve the issue, please perform the following steps

Step 1: Confirm if Password has been expired. 

  • Login to NSX manager as root user.
  • It shall be suggested to change the password stating about expiry. Please follow on-screen instructions to change the password.
  • Each NSX Edge node has 3 user accounts, namely, Root, Admin and Audit. To reset all user accounts or either of them, please follow the steps mentioned in Resetting the Passwords of an Appliance

Step 2: Out-of-band password changes. 

If NSX password has been changed outside SDDC manager, please remediate by following below mentioned steps.

  • Navigate to Password management in SDDC [ Administration> Security> Password Management]
  • Then click the tab 'NSX EDGE' / NSX MANAGER
  • Click the vertical ellipsis (three dots) next to the node whose password you are trying to remediate and click Remediate. 
  • Enter and confirm the password that was manually reset. 
  • Click Remediate 

 Repeat the steps for each of the affected user account (Admin and Audit) in SDDC manager.

If the issue persists after performing all the above steps, please raise a support case with Broadcom Global Support team to assist you further.

Additional Information