You are running SSP or Avi Operations and have encountered an alarm with any of the following description:
AI Assistant Platform {{ .ResourceID }} is degraded
AI Assistant Platform {{ .ResourceID }} is down
The {{ .ResourceID }} can be any of the following:
intelligent-assist-browser
intelligent-assist-edge
intelligent-assist-models
intelligent-assist-nginx
intelligent-assist-search
intelligent-assist-tutor
intelligent-assist-vdefend-dialog-0
vDefend SSP Version: 5.2 and later
Avi Operations: 5.2 and later
Resource Exhaustion: High CPU, memory, or disk usage that causes the node to become unresponsive or unstable.
Kubernetes Node Failures: Issues with Kubernetes node components such as the kubelet, or node being marked as "NotReady" due to insufficient resources, failed pods, or crashed components.
Steps to resolve:
Check AI Assistant disk usage, memory usage, CPU usage alarms.
Try re-starting the deployment/statefulset. This should take care of any transient issues. This will impact any ongoing chat conversations.
Log into SSP-Installer using 'sysadmin' credentials
Get the pod name for the {{ .ResourceID }} , using 'k -n nsxi-platform get pods | grep {{ .ResourceID }}'
k -n nsxi-platform get pod <pod-name> -o jsonpath='{.metadata.ownerReferences[0].kind}'
Confirm the output is ReplicaSet and run:
k -n nsxi-platform rollout restart deployment {{ .ResourceID }}
If none of the above is applicable, please open a ticket with Broadcom Support.