LCMVCF19112: VCF 9.0 Could not get API token from SDDC Manager.
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LCMVCF19112: VCF 9.0 Could not get API token from SDDC Manager.

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Article ID: 413752

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Updated On:

Products

VMware SDDC Manager VMware Cloud Foundation

Issue/Introduction

  • Below error observed from VCF Ops UI



  • A similar error is observed in the Fleet Manager's vmware_vrlcm.log

/var/log/vrlcm/vmware_vrlcm.log

YYYY-MM-DDT13:45:39.600Z INFO vrlcm[1299] [pool-3-thread-89] [c.v.v.l.v.p.t.CreateServiceAccountForVrealizeInSddcManagerTask]  -- Service account username: svc-ops-sddc-manager-###-#

YYYY-MM-DDT13:45:39.601Z INFO vrlcm[1299] [pool-3-thread-89] [c.v.v.l.p.d.VCFRestClient]  -- Connect URL : https://incorrectFQDN/v1/tokens
YYYY-MM-DDT13:45:51.710Z ERROR vrlcm[1299] [pool-3-thread-89] [c.v.v.l.p.d.VCFRestClient]  -- Exception occurred while getting VCF access token.
java.net.NoRouteToHostException: No route to host (Host unreachable)
        at java.base/java.net.PlainSocketImpl.socketConnect(Native Method) ~[?:?]
        at java.base/java.net.AbstractPlainSocketImpl.doConnect(Unknown Source) ~[?:?]
        at java.base/java.net.AbstractPlainSocketImpl.connectToAddress(Unknown Source) ~[?:?]
        at java.base/java.net.AbstractPlainSocketImpl.connect(Unknown Source) ~[?:

Environment

VMware Cloud Foundation 9.x

Cause

The task failed due to stale reference to an old VCF Installer in the Fleet Manager appliance. 

Resolution

The resolution for the reported issue involves Fleet Manager DB changes. Open a support case with Broadcom support.