Unable to add virtual machines to the Protection Group
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Unable to add virtual machines to the Protection Group

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Article ID: 413743

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptoms

  • Unable to add virtual machines to the Protection Group. The task fails with the following error:

    Operation Error: Unable to associate virtual machine 'VM_NAME' with protection group 'PG_NAME' because this virtual machine is already associated with protection group 'unknown'.

  • The affected VMs are not listed in any existing Protection Group.

  • The Reprotect operation for the corresponding Recovery Plan fail.

  • The VMs and Protection Group is manually deleted or removed.

  • When attempting to create a new Protection Group, the VMs do not appear in the list of available replicated VMs.

  • In vSphere Replication, the VMs appear as replicated, but they are not mapped to any PG in SRM.

  • Verified the SRM database, and there are no existing entries for the affected VMs in any SRM DB tables.

Environment

  • Site Recovery Manager 8.x
  • Live Recovery 9.x

Cause

  • The SRM database did not have valid entries for the problematic VMs. This can occur if the previous SRM operations (such as Reprotect or PG deletion) did not clean up the database entries properly.
  • The inconsistency in the SRM database prevented SRM from adding the VMs to a Protection Group. As SRM still recognizes the VM as being part of an “unknown” PG, any attempt to add it to a new group failed with the error.

Resolution

  1. Reboot the SRM appliance to refresh the internal state and clear any cached process references.

  2. Once the SRM service is back online, re-add the VMs to the intended Protection Group.