24.4.X The Service Manager Dialog does not show connections for Java-based server processes with Oracle Java 17
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24.4.X The Service Manager Dialog does not show connections for Java-based server processes with Oracle Java 17

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Article ID: 413590

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Automation Engine 24.4.X: The Service Manager Dialog does not show connections for Java-based server processes with Oracle Java 17

Cause

Limitation of Oracle Java installer

Resolution

This is being caused by how Oracle JDK gets installed and how Oracle JDK works.  When it runs a java -jar command, it uses a wrapper for launching apps.  This is located in something like C:\Program Files\Common Files\Oracle\Java\javapath whereas the java in java's /bin needs to be used in order to have this show the connections.

This is a feature/limitation of Oracle JDK installer (hence this starting after the java version upgrade) and not something that Automic can change. 

Resolution:

In order to have these show up with the current Oracle JDK installation, specify the full path to java's /bin/java program before the JxP start command. 

For instance, the following is currently used to start the JWPs:

java -Xrs -Xmx2G -jar ucsrvjp.jar -IE:\Automic\ServiceManager\bin\..\..\AutomationEngine\bin\ucsrv.ini -svc%port% -role=AUT

This must be changed to:

"C:\Program Files\Java\jdk-17\bin\java" -Xrs -Xmx2G -jar ucsrvjp.jar -IE:\Automic\ServiceManager\bin\..\..\AutomationEngine\bin\ucsrv.ini -svc%port% -role=AUT

For all JCP, JWP, or REST processes, to show the connection, update any start command that has java -[something] to "C:\Program Files\Java\jdk-17\bin\java" -[something]

Further information on why this is happening will need to come from Oracle support.