vCenter/Hosts Connection to KMS server is broken.
search cancel

vCenter/Hosts Connection to KMS server is broken.

book

Article ID: 413587

calendar_today

Updated On:

Products

VMware vSAN

Issue/Introduction

Alert: vCenter Server or any of the ESXi hosts experience problems when connecting to Key Management Servers (KMS) alert from Aria. 

 

==Alert from Aria Operations for Logs (formerly known as vRealize log insight)==

Alert Definition Name: vCenter Server or any of the ESXi hosts experience problems when connecting to Key Management Servers (KMS).
Alert Definition Description: The test verifies whether vCenter Server and ESXi hosts can connect to Key Management Servers (KMS). Unsuccessful test indicates that vCenter Server or any of the hosts experience problems when connecting to KMS.
Object Name : vSAN Cluster(cluster-name)
Object Type : VirtualSANDCCluster
Alert Impact: health
Alert State : critical
Alert Type : Storage
Alert Sub-Type : Availability
Object Health State: 4.0
Object Risk State: 1.0
Object Efficiency State: 1.0
Control State: Open
Symptoms:
SYMPTOM SET - self
Symptoms -
Symptom NameObject NameObject IDMetricMessage InfoCheck if vCenter Server or any of the ESXi hosts experience problems when connecting to Key Management Servers (KMS) resulted in error.vSAN Cluster(cluser-name)
Recommendations:
- See VMware KB 2149497 to troubleshoot this alert.

*This alert may also show in the historical health data in vSAN (Skyline Health).

Environment

vSAN 7.0

vSAN 8.0

Cause

Built in Azure KMS had short intermittent connectivity issues. 

Resolution

Work with the KMS provider vendor to investigate and resolve KMS connectivity issues.

  • For Azure built in KMS, this is handled by Microsoft. Where Microsoft would be involved in investigation of KMS connectivity.
     

Any technical issues found with the vendor KMS are handled by the corresponding vendor as described in the 3rd party support documentation

Additional Information