Getting an error while discovering the Device | getNext | getBulk
search cancel

Getting an error while discovering the Device | getNext | getBulk

book

Article ID: 413558

calendar_today

Updated On:

Products

VMware Smart Assurance

Issue/Introduction

You are getting below errors while discovering the Cisco devices:

SWFE-E-EMAX-Agent responses to "getNext" reach the limitation of number of instances: 500, Agent: <device>, Current Root OID: .1.3.6.1.2.1.47.1.1.1.1.5 
SWFE-E-EMAX-Agent responses to "getBulk" reach the limitation of number of instances: 500, Agent: <device>, Current Root OID: .1.3.6.1.2.1.47.1.1.1.1.5

Environment

All supported releases of Smart

Cause

  • Smart IP has maxInstances set to 500 for drivers that walk the Cisco entityMIB.

  • This flag is used by SNMPWalkFE that gets the all the getBulk oids and feeds it to the ASL

  • It is to stop unwanted behavior when lot of OIDs values are fed to the ASL driver at one shot. So, it is limited to 500.

Resolution

  • Using snmpwalk check the number of occurrences of OID reported in the discovery error. It should be more than 500. For example:

    • snmpwalk -v 2c -c <community> <device_ip> 1.3.6.1.2.1.47.1.1.1.1.5|wc -l

  • Using sm_edit change the occurrences of  "maxInstances = 500" to "maxInstances = <number from the output of above command + some buffer>" in SMARTS_BASEDIR/conf/discovery/DISCOVERY_CISCO.import

    • ./sm_edit conf/discovery/DISCOVERY_CISCO.import

  • Re-discover the device.

  • Restart IP domain and then re-discover the device if just re-discovery does not fix the issue.