Getting error "Failed to connect to source appliance vcenter.com port 443: [Errno 111] Connection refused" while upgrading vcenter 7 to vCenter 8 at Stage II
search cancel

Getting error "Failed to connect to source appliance vcenter.com port 443: [Errno 111] Connection refused" while upgrading vcenter 7 to vCenter 8 at Stage II

book

Article ID: 413512

calendar_today

Updated On:

Products

VMware vCenter Server 8.0

Issue/Introduction

While connecting to source vcenter server  at stage II before prechecks, we get below error:

 "Failed to connect to source appliance vcenter.com port 443: [Errno 111] Connection refused"


When running curl -v telnet://<target_vcsa_ip>:443, from 8.x appliance to source vcenter, the connection gets rejected all the time. Vice-A-Versa works.


Environment

vCenter 7.X
vCenter 8.X

Cause

This issue arises when the vCenter Appliance 8.x, the source vCenter, and the ESXi host managing both are all configured within the same subnet. In this scenario, the external firewall does not plays any role in blocking the port or IP. On the other hand, vCenter`s local firewall rules are configured in vCenter`s management portal (VAMI)

Resolution

Please add one 'allow' rule in vcenter`s firewall specifying the temporary IP of 8.x appliance and re-order it to top.

Please find the steps below.

1) Access Management portal of vCenter server.
2) Go to 'Firewall' as shown below.

3) Click Add and configure the appliance`s temporary IP as shown below and save it.

4) Please re-order the temporary IP on top and save the configuration.