vCenter stage 2 upgrade pre-check fails with error "Internal error occurs during pre-upgrade checks."
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vCenter stage 2 upgrade pre-check fails with error "Internal error occurs during pre-upgrade checks."

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Article ID: 413489

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

vCenter stage 2 upgrade pre-check fails with error:

Internal error occurs during pre-upgrade checks. 
Resolution  Please search for these symptoms in the VMware Knowledge Base for any known issues and  possible resolutions. If none can be found, collect a support bundle and open a support request.

 

From target vCenter ssh,
 
/var/log/vmware/upgrade/pre-checks.json logs throw below error:
 
prechecks.json
 
{
    "componentRequirements": [],
    "requirementsMismatch": {
        "warning": [],
        "error": [
            {
                "text": {
                    "id": "ur.requirements.internal.text",
                    "translatable": "Internal error occurs during pre-upgrade checks.",
                    "localized": "Internal error occurs during pre-upgrade checks."
                },
                "description": null,
                "resolution": {
                    "id": "ur.internal.resolution",
                    "translatable": "Please search for these symptoms in the VMware Knowledge Base for any known issues and possible resolutions. If none can be found, collect a support bundle and open a support request.",
                    "localized": "Please search for these symptoms in the VMware Knowledge Base for any known issues and possible resolutions. If none can be found, collect a support bundle and open a support request."
                },
                "problemId": null
            }
        ]
    },
 
 
No specific errors seen but only general errors in /var/log/vmware/upgrade/requirements-upgrade-runner.log:
 
YYYY-MM-DDTHH:MM:SS ERROR __main__ ERROR: Fatal error during upgrade REQUIREMENTS. For more details take a look at: /var/log/vmware/upgrade/requirements-upgrade-runner.log
Traceback (most recent call last):
File "/usr/lib/vmware/cis_upgrade_runner/libs/sdk/shell_utils.py", line 122, in set
    raise ShellSessionException('Cannot change appliance login shell from %s to %s',
shell_utils.ShellSessionException: ('Cannot change appliance login shell from %s to %s', '<html>\n<head>\n\t<title>Fireware XTM User Authentication</title>\n    <noscript>\n        The Fireware XTM User Authentication web page requires that JavaScript\n        be enabled in your Web Browser. \n        \n        Please retry after enabling JavaScript in your browser. You can use\n        the browser\'s Back button to return to the page you were previously\n        viewing.\n    </noscript>\n</head>\n<body>\n\t<script>\n        var newloc = "/wgcgi.cgi?action=fw_logon&fw_logon_type=status";\n        var search = window.location.search;\n        if (search.length > 1) {\n            search = search.substring(1);\n            newloc += "&" + search;\n        }\n        window.location = newloc;\n    </script>\n</body>\n</html>', '/bin/bash')

 

Environment

VMware vCenter 8.0.x

Cause

Port 443  blocked from source ESXi host to source vCenter and target vCenter.

Resolution

According to the upgrade prerequisites, ensure that port 443 is not blocked by any firewall between the source ESXi host and source vCenter, source ESXi host and target vCenter.

 

Refer below KB to verify port connectivity from ESXi using netcat command:

https://knowledge.broadcom.com/external/article/341078/troubleshooting-network-and-tcpudp-port.html

Additional Information

Refer below:
https://techdocs.broadcom.com/us/en/vmware-cis/vsphere/vsphere/8-0/vcenter-server-upgrade-8-0/upgrading-and-updating-the-vcenter-server-appliance/prerequisites-for-upgrading-the-appliance.html