One or more nodes of VMware identity manager is in Quarantine state
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One or more nodes of VMware identity manager is in Quarantine state

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Article ID: 413460

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

 A secondary VMware Identity Manager (vIDM) node enters a quarantined state. checking cluster status using the poolnodes command on vIDM, the secondary node shows as quarantined, and PCP recovery using the referenced KB fails.

Environment

vIDM 3.3.7

Cause

This issue typically occurs when:

  • A vIDM node has been offline for several days, causing replication delays and inconsistencies.
  • PCP recovery fails due to prolonged downtime.

Resolution

Step 1: Reboot only the Quarantined Node

If the quarantined node is not the primary node, perform a graceful reboot of the affected node. ( Follow the section "Single node VMware Identity Manager" as per KB: Graceful Shutdown and Power On of a VMware Identity Manager PostgreSQL cluster )

  • After the reboot, verify whether the node rejoins the cluster.
  • For any replication delay on recovered node perform PCP recovery.

if effected node is still in Quarantined mode, Perform the following steps

Step 2: Perform Graceful Shut Down the Entire Cluster

  1. Perform a graceful shutdown of all vIDM nodes in the cluster. ( Follow the section "Clustered VMware Identity Manager" as per KB: Graceful Shutdown and Power On of a VMware Identity Manager PostgreSQL cluster )
  2. Bring the nodes up First Primary and followed by secondary nodes.
  3. For any replication delay on recovered node perform PCP recovery.

Additional Information