Can't get hDB from pool
search cancel

Can't get hDB from pool

book

Article ID: 413425

calendar_today

Updated On:

Products

CA Harvest Software Change Manager CA Harvest Software Change Manager - OpenMake Meister

Issue/Introduction

After I get into the Login Page and enter user and passwrod  I have this message

harweb.LogOn.service(): Error while processing CMD=LogOn<br>harweb.HServlet.getHDB(): Can't get hDB from pool. Check your 'harweb.cfg' and restart your servlet server.

Environment

Harvest Software Change Manager v14.5.0

Cause

Tomcat's <tomcat home>\logs\localhost<date>.log file shows:

<date> <time> SEVERE [Catalina-utility-2] org.apache.catalina.core.ApplicationContext.log Servlet.init() for servlet [StartupServlet] threw exception
 java.lang.UnsatisfiedLinkError: C:\Program Files\Apache Software Foundation\Tomcat 9.0\webapps\harweb\WEB-INF\lib\jhcomm64.dll: Can't find dependent libraries
 at java.base/jdk.internal.loader.NativeLibraries.load(Native Method)


The trouble appears to be the folder to which Tomcat was installed - "C:\Program Files\Apache Software Foundation\Tomcat 9.0".  It contains spaces and those are causing Harweb to not be able to find everything it needs.

Resolution

Recommend reinstalling Tomcat to a shorter folder name that does not contain spaces, for example "C:\Tomcat9", then reinstalling Harweb using this new shorter folder as the Tomcat "home" folder.

Additional Information

For SCM v14.5.0, Harweb requires Tomcat v9.x and AdoptOpenJDK v11.

For SCM v14.5.01, Harweb requires Tomcat v10.x and AdoptOpenJDK v17.

Installation instructions for Harweb can be found here: Install CA Harvest SCM Web Interface

Tomcat's catalina<date>.log and localhost<date>.log can be found in the <tomcat home>\logs folder.