Aria Operations Upgrade Stuck at Stage 2 of 14 (Distributed)
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Aria Operations Upgrade Stuck at Stage 2 of 14 (Distributed)

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Article ID: 413387

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

During the upgrade of Aria Operations, the process may become stuck at Stage 2 of 14 when processing a Distributed PAK file. This issue is observed through the Admin UI > Software Update, where the upgrade does not progress beyond this stage. And this can happen on multiple nodes at the same time. 



Error in /storage/log/vcops/log/casa/casa.log
INFO [ajp-nio-127.0.0.1-8011-exec-1] [6h0000Jf] support.subprocess.GeneralCommand:255 - Command '/usr/bin/sudo -n /usr/lib/vmware-python-3/bin/python /usr/lib/vmware-casa-b2b/casa-b2b/pakManager/bin/vcopsPak
Manager.py --action query_pak_detail --pak vRealizeOperationsManagerEnterprise-818324521385 --json --force_content_update false' threw exception: CommandLineExitException: key=general.failure; args=2,/usr/lib/vmware-python-3/bin/python:
can't open file '/usr/lib/vmware-casa-b2b/casa-b2b/pakManager/bin/vcopsPakManager.py': [Errno 2] No such file or directory; 
cause=ERROR [ajp-nio-127.0.0.1-8011-exec-1] [6h0000Jf] upgrade.pak.PakService:1496 - exception when checking whether pre-upgrade validation results available, reason is CommandLineExitException: key=general.failure;
args=2,/usr/lib/vmware-python-3/bin/python: can't open file '/usr/lib/vmware-casa-b2b/casa-b2b/pakManager/bin/vcopsPakManager.py': [Errno 2] No such file or directory;
cause=com.vmware.vcops.casa.support.CommandLineExitException: CommandLineExitException: key=general.failure; args=2,/usr/lib/vmware-python-3/bin/python: can't open file '/usr/lib/vmware-casa-b2b/casa-b2b/pakManager/bin/vcopsPakManager.py': [Errno 2] No such file or directory

Environment

Aria Operation 8.x

Cause

The upgrade process attempts to execute the Python script vcopsPakManager.py as part of the pre-upgrade validation for the PAK file. However, the script is not found at the expected path: 
/usr/lib/vmware-casa-b2b/casa-b2b/pakManager/bin/vcopsPakManager.py
This may occur due to a temporary issue during unpacking of the upgrade files and the CASA service not initializing the environment correctly on the first attempt. As a result, the system fails to retrieve PAK details and halts the upgrade at stage 2.

Resolution

Please follow the steps as below to resolve the issue and resume the upgrade 
  • Log in to the Admin UI as admin user account and take a note of the node(s) that are stuck at Stage 2 of 14.
  • SSH into the affected node as the root user.
  • Restart the CASA service by running: 
    service vmware-casa restart
  • Wait for a few minutes , the Admin UI may not load immediately.
  • Once the Admin UI (https://<Aria_Ops_FQDN_IP>/admin) becomes available, log in as the admin user.
  • Navigate to Software Update.
  • The upgrade should now resume and proceed successfully.

Additional Information

If the above steps do not resolve the issue, please refer to the following article for further troubleshooting:
Upgrade fails with error: Operation Failed. If the error persists, contact Broadcom Support