Unable to find matching tcabomrelease for k8s version: v1.29.15+vmware.1 on cluster: tkg-mgmt
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Unable to find matching tcabomrelease for k8s version: v1.29.15+vmware.1 on cluster: tkg-mgmt

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Article ID: 413366

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Updated On:

Products

VMware Telco Cloud Platform VMware Telco Cloud Platform - 5G Edition

Issue/Introduction

After upgrading the management cluster, the add-on upgrade task fails at 30%

 

Environment

TCP 5

Cause

This issue is observed in non-airgapped environments when the TCA BOM Release (TBR) for the Kubernetes version v1.29.15+vmware.1 is not available in the TCA database. This typically occurs when:

  • The TBR for the specified Kubernetes version has not yet been synced from the Broadcom repository.
  • The Kubernetes version string used in the cluster does not exactly match any of the available TBR entries.

Resolution

To address the mismatch of tcabomrelease, please perform the following steps:

Step 1: Export TBR from Working management Cluster

  • SSH into the master node of a working TKG management cluster.
  • Execute the following commands:
    kubectl get tbr -n tca-system
    kubectl get tbr -o yaml -n tca-system > tbr-3.4.yaml


Step 2: Transfer the YAML File

  • Download the tbr-3.4.yaml file from the working cluster.
  • Upload it to the control plane node of the problematic management cluster.


Step 3: Apply the TBR on the Affected Cluster

  • SSH into the affected cluster’s master/controlplane node.
  • Apply the TBR using the following command:
    kubectl apply -f tbr-3.4.yaml


Step 4: Retry the Operation

  • Go to the TCA UI> CaaS Infrastructure and choose the impacted management cluster upgrade add on option or Retry the Upgrade Add-ons operation.

         Example:

NOTE: At this stage "The missing TBR was successfully imported, and the upgrade/add-on operation completed without further errors."