VM not responding with error "blk_update_request : I/O error"
search cancel

VM not responding with error "blk_update_request : I/O error"

book

Article ID: 413321

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • Tenant reports VM is not reachable
  • ESXi where VM is hosted is running and no other VMs were affected
  • Underlying storage is also healthy 
  • vmotion VM to a different host and datastore does not resolve the issue
  • Upon opening VM's console we see bellow message:

Environment

8.0

Cause

The error "blk_update_request : I/O error" indicates a Linux kernel issue where it cannot successfully access a block storage device, such as a hard drive or SSD.

This can be caused by hardware problems with the drive or its connection (like a loose cable or bad port), bad sectors on the drive, outdated drivers or firmware, or file system corruption. 

Resolution

  • Contact the application owner for further analysis of VM
  • Redeploy VM or restore it from the latest good backup