Unable to add disk on vSAN ESA cluster using vCenter UI, getting an error as 'Unable to extract requested data. Check vSphere Client logs for details.'
search cancel

Unable to add disk on vSAN ESA cluster using vCenter UI, getting an error as 'Unable to extract requested data. Check vSphere Client logs for details.'

book

Article ID: 413317

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

vsan-plugin.log
[yyyy-mm-ddThh:mm:ss.984Z][WARN ][8.0.203.10000:1239927531][urn:vmomi:ClusterComputeResource:domain-c11632:30a6db4c-5eb2-4e1c-822c-787806c0bae0][com.vmware.vsan.client.h5vsanui.cluster.configure.vsan.diskManagement] ["[MEASURE](20597 ms) getCapabilities"]
[yyyy-mm-ddThh:mm:ss.990Z][WARN ][8.0.203.10000:1239927531][urn:vmomi:ClusterComputeResource:domain-c11632:30a6db4c-5eb2-4e1c-822c-787806c0bae0][com.vmware.vsan.client.h5vsanui.cluster.configure.vsan.diskManagement] ["[MEASURE](20587 ms) queryPhysicalDiskHealthSummary"]
[yyyy-mm-ddThh:mm:ss.997Z][ERROR][8.0.203.10000:1239927531][urn:vmomi:ClusterComputeResource:domain-c11632:30a6db4c-5eb2-4e1c-822c-787806c0bae0][com.vmware.vsan.client.h5vsanui.cluster.configure.vsan.diskManagement] ["[TRACE] (a5f4) listHosts -> (46d5) getDiskStatuses -> (7024) queryPhysicalDiskHealthSummary",{"id":"7024","fnName":"queryPhysicalDiskHealthSummary","input":{"startDate":"yyyy-mm-ddThh:mm:ss.651Z","fnArgs":[{"t
ype":"ClusterComputeResource","value":"domain-c11632","serverGuid":"30a6db4c-5eb2-4e1c-822c-787806c0bae0"}]},"output":{"endDate":"yyyy-mm-ddThh:mm:ss.243Z","fnErr":{"name":"TypeError","stack":"TypeError: Cannot read properties of undefined (reading 'childNodes')\n    at Qt 
..
..
[yyyy-mm-ddThh:mm:ss.016Z][ERROR][8.0.203.10000:1239927531][urn:vmomi:ClusterComputeResource:domain-c11632:30a6db4c-5eb2-4e1c-822c-787806c0bae0][com.vmware.vsan.client.h5vsanui.cluster.configure.vsan.diskManagement] ["[TRACE][END] (a5f4) listHosts",{"id":"a5f4","fnName":"listHosts","input":{"startDate":"yyyy-mm-ddThh:mm:ss.513Z","fnArgs":[{"type":"ClusterComputeResource","value":"domain-c11632","serverGuid":"30a6db4c-5eb2-4e1c-822c-787806c0bae0"}]},"output":{"endDate":"yyyy-mm-ddThh:mm:ss.244Z","fnErr":{"name":"Error","stack":"Error: Unable to extract requested data. Check vSphere Client logs for details.\n    at k.createWithOrigMessage 


Browser .har logs collected from Developer tools
The response from these logs:
{
  "entity": {
    "type": "HostSystem",
    "value": "host-6954",
    "serverGuid": null
  },
  "propertyName": null,
  "parameter": null,
  "task": null,
  "taskUid": null,
  "result": null,
  "effect": null,
  "error": {
    "cause": {
      "cause": null,
      "stackTrace": [],
      "obj": {
        "type": "HostSystem",
        "value": "host-6954",
        "serverGuid": null
      },
      "message": "Permission denied due to security policy",
      "faultCause": null,
      "faultMessage": null,
      "localizedMessage": "Permission denied due to security policy",
      "suppressed": []
    },
    "stackTrace": [],
    "message": "Permission denied due to security policy",
    "faultCause": {
      "cause": null,
      "stackTrace": [],
      "obj": {
        "type": "HostSystem",
        "value": "host-6954",
        "serverGuid": null
      },
      "message": "Permission denied due to security policy",
      "faultCause": null,
      "faultMessage": null,
      "localizedMessage": "Permission denied due to security policy",
      "suppressed": []
    },
    "faultMessage": null,
    "localizedMessage": "Permission denied due to security policy",
    "suppressed": []
  }
}

Environment

vCenter 8.x

Cause

Security application like Entrust used which redirects vcenter to different URL to access vcenter FQDN with proxy.

The API call to list vSAN nodes getting failed due to permission blocked by the Security app.

Resolution

Review the logs of the Security App (Entrust) and mitigate any issues identified on this app end.

Reach out the security application support team.