vIDM cluster experiencing problem with OpenSearch and RabbitMQ services.
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vIDM cluster experiencing problem with OpenSearch and RabbitMQ services.

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Article ID: 413281

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • The vIDM health check is returning a red status
  • The error 'There was a problem with Opensearch service' is received on one or more nodes.
  • The error 'There was a problem with Messanging Service'. is received on one or more nodes.
  • The Integrated components section of the vIDM admin UI may not load.

Environment

VMware Identity Manager 3.3.7

Cause

This can be caused when the '/db' partition of the cluster nodes becomes full. This can be confirmed by running the command below;

df -h

Resolution

There are three steps to resolving this issue.

  1. Follow the steps outlined in the KB below to clear large tables from the database;
  2. Run a stop/start cycle on Opensearch services
    • /etc/init.d/opensearch stop
      /etc/init.d/opensearch start
  3. Run a stop start cycle of RabbitMQ services
    • /etc/init.d/hoizon-workspace stop
      rabbitmqctl stop_app
      rabbitmqctl start_app
      /etc/init.d/hoizon-workspace start

Additional Information

To access the vIDM admin UI, add the extension '/SAAS/admin/systemDiagnostic' to the end of a node; FQDN.

https://<vIDM_node_FQDN>/SAAS/admin/systemDiagnostic

There is further information in the KB below to help troubleshoot RabbitMQ.