LWD-based Snapshot Fails with Error: "A specified parameter was not correct: syncId"
search cancel

LWD-based Snapshot Fails with Error: "A specified parameter was not correct: syncId"

book

Article ID: 413246

calendar_today

Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

Workflow Overview

Note: The vSAN Health Service manages the DPS service on your vCenter, this service will be working even if vSAN is not configured in your environment.

  1. The Backup Management Tool uses the VM Direct Engine to interact with vCenter APIs.

  2. The VM Direct Engine communicates with DPS (vSAN Health Service) within vCenter to initiate snapshot, sync, and restore operations.

  3. DPS determines the appropriate ESXi host for the operation and delegates the corresponding task.

  4. On the designated ESXi host, the DPD (Data Protection Daemon) service manages the protection workflow and interacts with the Backup Service running on the host (for example, TSDM service for Dell PPDM) to handle backup data operations.


Symptoms: 

During an LWD-based snapshot operation, the process may fail with the error message:

“A specified parameter was not correct: syncId”

  • Error noticed in vCenter UI Tasks:

 

  • Error noticed in Vendor Backup Manager:

 

  • In ESXi var/run/log/dpd.log you see entries similar to :

[YYYY-MM-DDTHH:MM:SS] dpd[2215779]: Missing syncId
[YYYY-MM-DDTHH:MM:SS] dpd[2215778]: No VendorId provided
[YYYY-MM-DDTHH:MM:SS] dpd[2215778]: Task 'Dp.Task.Snapshot.52######-####-####-####-########32fb' failed with error: 
(vmodl.fault.InvalidArgument) {
    invalidProperty = "vendorId"

 

  • In vCenter /var/log/vmware/vsan-health/vsanvcmgmtd.log you see entries similar to :

[YYYY-MM-DDTHH:MM:SS] error vsanvcmgmtd[63324] [vSAN@6876 sub=dps opId=########-##74] DPD LRO request failed, host: <host-ID>(<Host-Name>), api: Snapshot, pe: (dp.vpx.VirtualMachineProtectedEntity) {
-->    vmRef = 'vim.VirtualMachine:vm-<ID>',
-->    includedDiskKeys = (int) [
-->       2000,
-->       2001
-->    ]
--> }, dpdTask: 'vim.Task:Dp.Task.52######-####-####-####-########32fb', dpsVcTask: 'vim.Task:task-<task-ID>', dpd taskinfo: (vim.TaskInfo) {
-->    key = "Dp.Task.Snapshot.52######-####-####-####-########32fb",
-->    task = 'vim.Task:Dp.Task.Snapshot.52######-####-####-####-########32fb',
-->    name = "dp.ProtectionService.snapshot",
-->    descriptionId = "",
-->    state = "error",
-->    cancelled = false,
-->    cancelable = false,
-->    error = (vmodl.fault.InvalidArgument) {
-->       invalidProperty = "vendorId",
-->       msg = "",
-->    },
-->    progress = 0,
-->    reason = (vim.TaskReasonSystem) {
-->    },
-->    queueTime = "[YYYY-MM-DDTHH:MM:SS] ",
-->    startTime = "[YYYY-MM-DDTHH:MM:SS] ",
-->    completeTime = "[YYYY-MM-DDTHH:MM:SS] ",
-->    eventChainId = 0,
-->    changeTag = "0",
--> }
[YYYY-MM-DDTHH:MM:SS]error vsanvcmgmtd[63324] [vSAN@6876 sub=dps opId=#########-##74] Async LRO 'Snapshot' failed for 'vim.VirtualMachine:vm-<ID>', fault: (vmodl.fault.InvalidArgument) {
-->    invalidProperty = "vendorId",
-->    msg

Cause

The failure can occur if the vendorId or syncId values are missing or invalid. These identifiers are crucial for establishing proper communication between the DPS service in vCenter and the DPD service on each ESXi host during backup operations.

 

Resolution

To re-establish synchronization between the DPS (vSAN Health Service) and DPD services, follow the steps below:

  1. Restart the vSAN Health Service on the vCenter Server

    service-control --stop vmware-vsan-health && service-control --start vmware-vsan-health
  2. Restart the DPD and Vendor Backup Services on the Affected ESXi Host
    (For example, TSDM service for Dell PPDM)

    • /etc/init.d/dpd restart

    • /etc/init.d/tsdm restart