Unable to edit or delete security policies if filter is used in the NSX Manager UI
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Unable to edit or delete security policies if filter is used in the NSX Manager UI

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Article ID: 413231

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Updated On:

Products

VMware vDefend Firewall VMware vDefend Firewall with Advanced Threat Prevention

Issue/Introduction

In the NSX Manager UI, browse to Security > Distributed Firewall > Category Specific Rules 

Use a filter to locate a policy or a rule. In the filtered view, the Policy level options are disabled. 

This is observed in both federation and standalone NSX deployments. 

However, at the rule level edit options are available in a filtered view (NSX 4.1.0 onward)

Environment

NSX 3.2.4

NSX 4.x

Cause

This is an expected behavior. This was done to address the issue described in KB: https://knowledge.broadcom.com/external/article/317518

 

Resolution

Editing of policies in a filtered view will be available in an upcoming NSX release.