Clarity: Unable to access API documentation
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Clarity: Unable to access API documentation

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Article ID: 413213

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

When trying to access Clarity API documentation, the following error is obtained:

failed to parse JSON/YAML response

Following error is seen in the app-ca.log:

ERROR 2025-09-25 12:23:48,019 [https-openssl-nio2-8443-exec-114] ppm.rest (clarity:user:session:none) (4005487a-140f-4d95-8781-6ea0b32468ca) 
ResourceMetaData shouldn't be null for REST resource : custZObject

Cause

A custom investment marked as inactive and API Enabled flag set to False in the DB.

Resolution

Correct the configuration of the Custom Investment.