While trying to deploy a VCF environment using the VCF Installer appliance - this error is encountered in the UI -
Failed to import {0} metadata in SDDC Manager API Reference Token: XXXXXX
The /var/log/vmware/vcf/commonsvcs/vcf-commonsvcs.log file contains these errors -
IDENTITY_UNAUTHORIZED_ENTITY User is not authorized
com.vmware.evo.sddc.identity.model.error.UnauthorizeException: User is not authorized
CLIENT_IP_BLOCKED Client IP is blocked
com.vmware.evo.sddc.identity.model.error.BlockedException: Client IP is blocked.
Token creation request received from user : admin@local
Local account authenticate initiated
Local account is locked
LOCAL_ACCOUNT_LOCKED Local account is locked.
VCF 9.0
This issue occurs when multiple deployments are done using the same VCF Installer appliance and the environment is deployed multiple times (example: for testing purposes), with the same SDDC Manager fqdn specified - but different passwords.
Use different SDDC Manager fqdns when deploying the environment multiple times, i.e. a new SDDC Manager fqdn for each environment deployment cycle.
If the same SDDC Manager fqdn must be reused - deploy a new VCF Installer appliance.