Autoping to a specific WA Agent fails although the WA Agent is active.
search cancel

Autoping to a specific WA Agent fails although the WA Agent is active.

book

Article ID: 41318

calendar_today

Updated On:

Products

CA Workload Automation AE - Business Agents (AutoSys) CA Workload Automation AE - Scheduler (AutoSys) Workload Automation Agent CA Workload Automation AE - System Agent (AutoSys) Autosys Workload Automation

Issue/Introduction

The 'autoping -m agent_name' command to a specific agent fails with errors:

CAUAJM_W_10496 Agent on [agent_name] has not responded in a timely fashion. Try again later. [CA WAAE Autoping] 

CAUAJM_E_50281 AutoPing from the Scheduler WAS NOT SUCCESSFUL. 

 

 

Environment

Release:  Workload Automation AE 

Cause

The problem was caused by name resolution. WA Agent was not able to resolve WA Manager host name. The following errors were recorded in the WA Agent transmitter.log file:

00/08/20XX 00:00:12.345 SGT+0800 1 TCP/IP Controller Plugin.Transmitter pool thread <Slow:1>.CybTargetHandlerChannel.constructConversation[:1045] - Error connecting to ACE: cybermation.library.communications.CybConversationConnectException: Unknown host: manager_name.com.xxx

 

Resolution

Ensure that WA Agent can successfully resolve Manager's host name.  User may either add the Manager hostname to the hosts file on the WA Agent machine or update DNS so that the hostname can be resolved successfully.