HCX OSAM does not progress during initial sync
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HCX OSAM does not progress during initial sync

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Article ID: 413164

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Updated On:

Products

VMware HCX

Issue/Introduction

  • In the HCX Manager UI > Services > Migration > Mobility Groups > Select the Mobility Group > Select the VM, the status does not progress after some considerable time:


  • In the source VM, the following logs are being repeated and not progressing on data in the Sentinel logs:
    Windows: C:\ProgramData\VMware\HCX\OSAM\sentinel.log
    Linux: /var/log/vmware/hcx/osam/sentinel.log
    <timestamp> DEBUG srcID = ###########################, state = 0, chunkToRead = -1, nrChunksInReaderQ = 0
    <timestamp> DEBUG chunksToBeAcked= 0, len(resendChunksMap) = 0, nrChunksRetransmitted = 0 nrTotalChunkstransmitted = <Total_Number>
    <timestamp> DEBUG nrChunksInHasherQ = 0, nrChunksInTansmitrQ = <Queue_Size>, len(chunkRangeHashMap) = ####
    <timestamp> DEBUG srcID = ###########################, state = 0, chunkToRead = -1, nrChunksInReaderQ = 0

  • In the Sentinel appliance, the logs do not show the data being transmitted. The logs are found in /var/log/messages
    <timestamp> <Appliance-SGW> sdrd 1935 - - [Notice-sdr-rcm] : [sentinel_id] : Received SYNC_PROGRESS message
    <timestamp> <Appliance-SGW> sdrd 1935 - - [Notice-sdr-wdr] : [sentinel_id] : Successfully delivered TRANSMIT_ACKS message with 0 acks
    <timestamp> <Appliance-SGW> sdrd 1935 - - [Notice-sdr-rcm] : [sentinel_id] : Received SYNC_PROGRESS message
    <timestamp> <Appliance-SGW> sdrd 1935 - - [Notice-sdr-wdr] : [sentinel_id] : Successfully delivered TRANSMIT_ACKS message with 0 acks

  • The following command does not show progression after some minutes
    watch -n 10 'curl -k --cert /common/cs/hm_to_gw.pem --key /common/ks/hm_to_gw.pk8 https://<HCX-IP>:9443/sdr/receivers/<sentinel_id>?_return=control.stats  | python -mjson.tool'

    Output:

    {
        "control": {
            "stats": {
                "saved": <total transferred>,
                "total": <total size to be transferred>,
                "transmitted": <total transferred?,
                "cpId": ""
            }
        }
    }

Cause

This is a known issue, and it is still under investigation.

Resolution

This is a known issue impacting VMware HCX. Please open a support case with Broadcom Support and refer to this KB article.