''VMware Update Manager scan failed. Refer LCM and VUM log file. Manual intervention needed as upgrade failed during install stage." error when upgrading ESXi via SDDC Manager
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''VMware Update Manager scan failed. Refer LCM and VUM log file. Manual intervention needed as upgrade failed during install stage." error when upgrading ESXi via SDDC Manager

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Article ID: 413029

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  • ESXi upgrade via SDDC Manager failed with error 'VMware Update Manager scan failed. Refer LCM and VUM log file. Manual intervention needed as upgrade failed during install stage. Check for errors in the Icm log files located on SDDC Manager under /var/log/vmware/vcf/lcm. Please retry the upgrade once the upgrade is available again'.

  • From the Host Client, the ESXi version is updated indicating that the upgrade completed successfully.

  • On ESXi host, from /var/run/log/esxupdate.log:
    YYYY-MM-DDTHH:MM:SSZ esxupdate: ########: imageprofile: DEBUG: VIB VMware_bootbank_nsx-python-protobuf_2.6.1-19195979 is being removed from ImageProfile (Up
    dated) ESXi-7.0U3g-20328353-standard
    YYYY-MM-DDTHH:MM:SSZ esxupdate: ########: esxupdate: INFO: All done!

     

  • From the vSphere Client, the Host is in disconnected state.

  • On the vCenter Server, in /var/log/vmware/vmware-updatemgr/vum-server/vmware-vum-server.log:
    YYYY-MM-DDTHH:MM:SSZ info vmware-vum-server[########] [Originator@6876 sub=HU-Upgrader] [upgraderImpl 557] Component requires reboot, rebooting host example.hostname.com
    YYYY-MM-DDTHH:MM:SSZ verbose vmware-vum-server[########] [Originator@6876 sub=HostStatusChecker] [hostStatusChecker 225] Disconnecting host: example.hostname.com

Environment

SDDC Manager 5.x

VMware vSphere ESXi 8.x

Cause

  • The ESXi host was in a disconnected state on the vCenter Server due to which the update manager was not able to complete the scan task for the host.
  • The Host got disconnected from the vCenter after the upgrade task completed due to connection timeout on port 443 and 80.

Resolution

  • Ensure port 80 and port 443 is open between the ESXi and the vCenter Server.
  • Manually reconnect the ESXi host to the vCenter Server:
    • Right-click Host -> Connect
  • Retry the upgrade to get the host out of the error state.