{"message":"Identity Internal Server Error","code":"IDENTITY_INTERNAL_SERVER_ERROR","status":500}
/var/log/vmware/vcf/commonsvcs/vcf-commonsvcs.log, the following entries are observed:[YYYY-MM-DDTHH:MM:SS] ERROR [common,###########,####] [c.v.e.s.c.c.v.vsphere.VsphereClient,cs-exec-5] Failed to connect to https://<vCenter FQDN>:443/sdkcom.vmware.vim.vmomi.client.exception.SslException: javax.net.ssl.SSLHandshakeException: PKIX path validation failed: java.security.cert.CertPathValidatorException: validity check failedCaused by: javax.net.ssl.SSLHandshakeException: PKIX path validation failed: java.security.cert.CertPathValidatorException: validity check failedCaused by: sun.security.validator.ValidatorException: PKIX path validation failed: java.security.cert.CertPathValidatorException: validity check failed[YYYY-MM-DDTHH:MM:SS] ERROR [common,###########,####] [c.v.e.s.c.c.v.vsphere.VcManagerBase,cs-exec-5] Immediately throwing on SSL exceptionSDDC Manager 5.x
SDDC Manager 9.x
The issue is caused due to expired Machine SSL certificate on the Management vCenter. The SDDC Manager fails to establish a secure connection to vCenter due to SSL handshake failure.
Log in to the vCenter CLI and validate certificate status to confirm expiration by running the below command:
for i in $(/usr/lib/vmware-vmafd/bin/vecs-cli store list); do echo STORE $i; sudo /usr/lib/vmware-vmafd/bin/vecs-cli entry list --store $i --text | egrep "Alias|Not After"; doneTo resolve the issue, the expired Management vCenter certificate must be renewed or replaced.
Note:
Replace the Expired Machine SSL Certificate Using One of the Following Methods:
vCert Tool: Use vCert to automate expired certificate replacement.
fixcerts Script: Replace certificates using the built-in fixcerts utility.
vSphere Certificate Manager: Manually replace certificates using the Certificate Manager utility.
Restart vCenter Services:
After replacing the certificates, restart services with the following command:
service-control --stop --all && service-control --start --all