Protection Engine console error "Unable to get data for the requested report" when attempting to generate a report
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Protection Engine console error "Unable to get data for the requested report" when attempting to generate a report

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Article ID: 412837

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Updated On:

Products

Protection Engine for NAS Protection Engine for Cloud Services

Issue/Introduction

  • After upgrading Symantec Protection Engine (SPE) for NAS from version 8.2.2.7 to 9.2.1, SPE console displays the error message "Unable to get data for the requested report" when attempting to generate a report.

  • While generating the report getting BadRequest, with Sever Response - Failed events in console logs:

  • SPE logs : 

  • Removing and re-adding SPE server to console also does not help.
  • From storage-end there are no errors. The connection shows successful and connected.
  • Change logging format to verbose
  • cmaf logs then shows the actual error. In this case the exception with the time format appears separated by dot, even though the format to generate is mm:dd:yyyy
  • Eg. In the regional format, if it is set to Indonesia (Indonesia), this has the time format separated by dot (.) instead of colon (:)

Environment

  • SPE Console version: 9.2.1.25
  • SPE version: 9.2.1

Cause

The time format appears separated by dot (.), even though the format to generate is colon (:), mm:dd:yyyy .

Resolution

Set the correct Regional format in Regional setting (OS).
This should be able to generate the report successfully showing correct date format with separator as colon (:)