Cannot undelete ZTNA application should an admin accidently remove it
search cancel

Cannot undelete ZTNA application should an admin accidently remove it

book

Article ID: 412737

calendar_today

Updated On:

Products

Symantec ZTNA

Issue/Introduction

ZTNA admin has added segment/TCP/Web/SSH/RDP applications manually.

After accidently deleting an application, ZTNA admin realised there was no backup or undelete option.

How can an admin undo a delete operation, or can the Cloud SWG ops team restore it?

Environment

ZTNA Administration Portal.

Backup/restore options.

Cause

No option exists to undo the process for now, but the information is available to recreate it.

Resolution

Using the ZTNA Audit logs, identify the DELETE operation and click CHANGES. This will highlight the key application details that would allow an easy recreation, as shown below:

A feature request has been added to either allow UNDO the changes, or provide an API interface that we use to send the metadata information above (which we do with the CHANGES link), to re-create an application quickly if needed.