There is no edit button available in 'Network Pool' option.
search cancel

There is no edit button available in 'Network Pool' option.

book

Article ID: 412735

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

There is no edit button available in 'Network Pool' option when the network tenancy is enabled for the organization in vCD.

Provider Portal >> Cloud Resources(tab) >> Network Pools >> No 'edit' option available when we open any available network pool.

Environment

vCloud Director 10.x
NSX 4.x

Cause

When an OrgVDC has tenancy enabled, the network pool cannot be selected or updated. This is because the OrgVDC will use the network pool backed by the systemwide default overlay Transport Zone in the backing network provider.

The same behavior is reflected in the OrgVDC creation wizard. If “networking tenancy” is enabled, the option to select a network pool will be unavailable. Disabling it, however, allows the user to select from available network pools.

This change was implemented as part of enhancements to support Networking Tenancy.

Resolution

It is expected behavior in vCD when using network-tenancy.