NSX host Transport node not getting unprepared while moving out of cluster with NSX hosts
search cancel

NSX host Transport node not getting unprepared while moving out of cluster with NSX hosts

book

Article ID: 412711

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

  • When an ESXi host is removed from an NSX-T prepared cluster, it's generally expected that the host will automatically unprepare from NSX.
  • However, this automatic unpreparation fails if the cluster was configured without a Transport Node Profile (TNP).
  • When the cluster does not have a TNP applied, when you move the host out of the cluster, the TN will not be unprepared automatically.

Environment

VMware NSX

Cause

Automatic preparation and unpreparation of ESXi hosts, particularly when added to or removed from a cluster, rely on the presence and management of a Transport Node Profile (TNP) at the cluster level.

If a cluster lacks an associated TNP, the NSX Manager cannot automatically trigger the unpreparation process when a host is removed, leaving the host in its last known NSX-T prepared state.

Resolution

Option 1: Apply the TNP that matches the host configuration to the entire cluster and try unpreparing the host by removing out from the Cluster (with TNP) to the DC level.

Option 2: If you cannot apply a TNP to the cluster and want to remove NSX for the host in the cluster.

Manually Uninstall NSX 

 

  • If manual uninstallation is required:

    • Go to the NSX UI and remove NSX from the host.

    • Ensure that all NSX VIBs are removed from the ESXi host.

    • The host status should change to "Unconfigured".

Reference:
Uninstall NSX from a standalone ESXi host – Broadcom Documentation


Additional Information

Important Note:

Before proceeding with NSX uninstallation, please verify the install/uninstall mappings and ensure that:

  • The host is using NVDS, and

  • The vmk0 interface is part of the NVDS.

Failing to verify this may result in the host entering a "Not Responding" state due to loss of management network connectivity.

If the Host Becomes Unresponsive:

If the host becomes unresponsive due to the above condition, please refer to the following KB article for recovery steps:
Host loses management network connection after NSX uninstall (Broadcom KB 406831)