DCS Agents on Oracle Linux went Offline after OS patching
search cancel

DCS Agents on Oracle Linux went Offline after OS patching

book

Article ID: 412706

calendar_today

Updated On:

Products

Data Center Security Server Advanced

Issue/Introduction

The OS has been recently upgraded from OEL kernel 5.15.0-307.178.5.el9uek to 6.12.0-1.23.3.2.el9uek.

After reboot, DCS Agents stopped communicating with DCS Manager and went Offline.

Environment

DCS 6.10 Agents on Oracle Enterprise Linux 5.15.0-307 upgraded to 6.12.0-1.23. 

Cause

Most likely, Agent startup scripts were removed from /etc/init.d directory during reboot after OS kernel upgrade.

As a result, the Agent was unable to initialize its modules and start daemons. 

/usr/lib/symantec/status.sh
 
Symantec Agent for Linux
Symantec Endpoint Protection (Cloud) 14.3.9537.9000
Symantec Data Center Security Server Agent (DCS) 6.10.0.9537
 
Daemon status:
  cafagent             not running
  sisamdagent          running
  sisidsagent          running
  sisipsagent          not running
  sisipsutil           running
 
Module status:
Missing driver startup script /etc/init.d/sisevt.init
  sisevt               not loaded
Missing driver startup script /etc/init.d/sisap.init
  sisap                not loaded
Missing driver startup script /etc/init.d/sisids.init
  sisfim               not loaded
Missing driver startup script /etc/init.d/sisips.init
  sisips               not loaded
 
Communication status:
CAF and/or AMD daemon did not start successfully. Bypassing communication check

Resolution

The Agent needs to be reinstalled and the server rebooted in order to restore full functionality.