VMware Live Site Recovery failed to reconfigure due to com.vmware.vapi.endpoint.failedToLoginMaxUserSessionCountReached
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VMware Live Site Recovery failed to reconfigure due to com.vmware.vapi.endpoint.failedToLoginMaxUserSessionCountReached

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Article ID: 412647

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

 

VMware Live Site Recovery (a.k.a. SRM) failed to reconfigure due to below error.

    "ERROR": 
        "com.vmware.vapi.std.errors.service_unavailable": 
            "data": 
                "OPTIONAL": null
            ,
            "error_type": 
                "OPTIONAL": "SERVICE_UNAVAILABLE"
            ,
            "messages": [
                
                    "STRUCTURE": 
                        "com.vmware.vapi.std.localizable_message": 
                            "args": [
                                "550",
                                "550",
                                "#####@VSPHERE.LOCAL"
                            ],
                            "default_message": "User session count is limited to 550. Existing session count is 550 for user #####@VSPHERE.LOCAL.",
                            "id": "com.vmware.vapi.endpoint.failedToLoginMaxUserSessionCountReached",
                            "localized": 
                                "OPTIONAL": null
                            ,
                            "params": 
                                "OPTIONAL": null
            ]

Environment

VMware Site Recovery Manager
VMware Live Site Recovery

Cause

This could happen when vapi-endpoint service of vCenter Server used up every available session for the user.

You can see error message in vCenter Server's /var/log/vmware/vapi/endpoint/endoint.log.

YYYY-MM-DDThh:mm:ss.###Z | WARN  | sso5                      | BaseSessionImpl                | 86614ccd-3206-433e-90ee-6378ff2c7122 | User sessions count is limited to 550. Existing sessions are 550 for user ###@VSPHERE.LOCAL. Please retry the login operation

Resolution

Restarting vapi-endpoint service of vCenter Server will release all the existing session and resolve the problem.

# Exec this command in vCenter Server's shell
service-control --restart vapi-endpoint

If you need to identify the reason why vapi-endpoint used up its session, raise a support case.