Inventory sync is failing in Aria Lifecycle for vIDM environment with the error code: LCMVIDMIMPORT0022
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Inventory sync is failing in Aria Lifecycle for vIDM environment with the error code: LCMVIDMIMPORT0022

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Article ID: 412575

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

Actions on vIDM in Aria Lifecycle fail with an error similar to:

Error Code: LCMVIDMIMPORT0022
vIDM import failed due to IO error on the vIDM host.
failed: Connection refused (Connection refused)

Environment

  • VMware Identity Manager 3.3.7
  • Aria Lifecycle 8.x

Cause

Aria Lifecycle is unable to complete any action on the vIDM nodes due to some issue with vIDM.

Resolution

Investigation should be carried out to ensure the vIDM UI is up and running with no errors displayed in the system diagnostic page.

Step through the Troubleshooting VMware Identity Manager postgres cluster deployed through Aria Suite Lifecycle to ensure Identity Manager does not have any issues.

 

Additional Information

In one case the LCMVIDMIMPORT0022 error was caused by /opt/vmware/horizon being 100% full and as a consequence the horizon-workspace service had stopped on two of the three vIDM nodes.

  1. Space was cleared in /opt/vmware/horizon following How to zip and remove old vIDM logs in vIDM appliance and clean up syslog
  2. service horizon-workspace start