Creating a new VM fails with the error "Network Adapter cannot attach to any port group"
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Creating a new VM fails with the error "Network Adapter cannot attach to any port group"

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Article ID: 412543

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Updated On:

Products

VMware NSX

Issue/Introduction

  • While navigating to System >> Compute Managers, you see an alarm with respect to the EAM service being down.
  • Note : The Compute Manager's connection status will be displayed as Up as seen below :

Environment

VMware NSX-T 

Cause

EAM experiences impact, an alarm is raised while one of the NSX Manager nodes is the clusterEventLeader. The clusterEventLeader changes and following the change, the EAM issue is resolved but the alarm will not clear due to a bug in the alarm framework encountered when the leaders change.

Resolution

  • This issue is resolved in VMware NSX 4.2.0
  • Workaround :
  • Restart the proton service on the NSX Manager node reporting the alarm "EAM Status Down" using the below command:
  • Log in to the appliance as root.
    • root@nsx-mngr:~# service proton restart 

Additional Information

Also see the following document: