Ticket creation failed
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Ticket creation failed

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Article ID: 412441

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Updated On:

Products

DX SaaS

Issue/Introduction

Ticket creation failed for alerts with long message

Error from MDR:[{"messageType":"ERROR","messageText":"Value does not fall within the limits specified for the field","messageAppendedText":"(Field ID and Name - HPD:IncidentInterface_Create

Cause

Problem is with UIM alerts that are sent to O2 using the ConnectorAccelerator

Ticket being created is using the Ticket Enrichment Rules.

Incident Fields 

Description is map to O2 Message  

Detailed_Description map to O2 Message Details

CI Name map to O2 Host

 
The Description field in ITSM has a limit of 200 char and the O2 Message have around 580 characters.

Resolution

Edit connaccel.xml and add

<ColumnMap from="message" to="message" pattern="^(.{100}).*"/>

The number in between curly braces, in this case {100} truncates the message to 100 characters.