The installer is unable to connect to the vCenter Server Management Interface failure when deploying, restoring, or upgrading vCenter.
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The installer is unable to connect to the vCenter Server Management Interface failure when deploying, restoring, or upgrading vCenter.

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Article ID: 412440

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

When deploying a new vCenter, restoring vCenter from VAMI backup, or upgrading vCenter from one version to another (for instance, from vCenter 7.x to 8.x), Stage 1 gets to 99% then either completes or fails.

Before Stage 2 can start, there is an error message observed:

The installer is unable to connect to the vCenter Server Management interface.
Unable to proceed with stage 2 of the deployment process.
You may attempt to continue with stage 2 by logging into the vCenter Server at https://vCenterFQDN:5480

Environment

vCenter 7.x

vCenter 8.x

Cause

The wrong network was selected when deploying, restoring, or upgrading the vCenter.

You didn't select the same port group that vCenter normally uses.

The port group that the vCenter normally uses is set for "Static Binding" instead of "Ephemeral".

Resolution

Option 1:

Edit the vCenter networking in the VM Settings and select the correct port group.

Restart vCenter services or restart vCenter.

service-control --stop --all && service-control --start --all

Option 2:

  1. If the DVS port group is set to "Static Binding", create a new Standard switch and create a new port group.
  2. Tag the new port group with the correct vLAN for the vCenter VM.
  3. Add an uplink to the standard switch. (This may have to come from the DVS, if there are no unused uplinks. Moving host from DVS to standard switch using ESXi CLI commands.
  4. Assign the new port group the the vCenter VM.
  5. Try to ping the vCenter IP. If this is successful, proceed to step 6.
  6. log into the vCenter VAMI interface and start stage 2 of the restore.