License entries fail to populate under the Assets section of the vCenter Server UI
book
Article ID: 412413
calendar_today
Updated On:
Products
VMware vCenter Server
Issue/Introduction
Unable to assign license to vCenter Server (VCSA) or ESXi Hosts, because the assets do not appear in the licensing page.
The following is observed by navigating to Administration > Licenses > Assets :
Cause
This issue may occur due to the License service(vmware-cis-license) being unresponsive or out of sync.
Resolution
Access the VCSA using SSH with root credentials.
Restart the VCSA License service (vmware-cis-license) using the following commands: service-control --restart vmware-cis-license
If the licenses are not assigned to the hosts, after restarting the service, reconnect the hosts using one of the following methods : Note : Monitor the tasks on the VCSA and validate that no active tasks are running on the hosts.
Disable host monitoring in vSphere HA by navigating to the Cluster > Configure > vSphere HA > Edit
Disconnect and reconnect the hosts individually, from the VCSA, using the following steps :
Right-click the host in the vSphere Client inventory and select Connection > Disconnect
Right-click the host in the vSphere Client inventory and select Connection > Connect
Disconnect and reconnect all the hosts from the VCSA, using the following steps :
Navigate to the Cluster > Hosts.
Select all using the checkbox.
Right click on the selection > Connection > Disconnect
After all the hosts are disconnected, right click on the selection > Connection > Connect.