License entries fail to populate under the Assets section of the vCenter Server UI
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License entries fail to populate under the Assets section of the vCenter Server UI

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Article ID: 412413

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • Unable to assign license to vCenter Server (VCSA) or ESXi Hosts, because the assets do not appear in the licensing page. 
  • The following is observed by navigating to Administration > Licenses > Assets :

Cause

This issue may occur due to the License service(vmware-cis-license) being unresponsive or out of sync.

Resolution

  • Access the VCSA using SSH with root credentials.
  • Restart the VCSA License service (vmware-cis-license) using the following commands:
    service-control --restart vmware-cis-license

  • If the licenses are not assigned to the hosts, after restarting the service, reconnect the hosts using one of the following methods :
    Note : Monitor the tasks on the VCSA and validate that no active tasks are running on the hosts.

    • Disable host monitoring in vSphere HA by navigating to the Cluster > Configure > vSphere HA > Edit
    • Disconnect and reconnect the hosts individually, from the VCSA, using the following steps : 
      1. Right-click the host in the vSphere Client inventory and select Connection > Disconnect
      2. Right-click the host in the vSphere Client inventory and select Connection > Connect
    • Disconnect and reconnect all the hosts from the VCSA, using the following steps :
      1. Navigate to the Cluster > Hosts.
      2. Select all using the checkbox.
      3. Right click on the selection > Connection > Disconnect
      4. After all the hosts are disconnected, right click on the selection > Connection > Connect.