Host is down after changing NIC aliases
search cancel

Host is down after changing NIC aliases

book

Article ID: 412410

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Two possible causes for this behavior:

  1. After attempting to re-alias NICs, the ESXi host did not come back up on the network. 

    OR

  2. The aliases were not actually changed. 

Environment

VMware ESXi

Cause

  1. If the NICs aliases were changed either by the ESXi host on command line and rebooted or via the physical switch, the PCI identifier is now changed. What this means is, the ESXi host may still be using the incorrect NIC. 

    OR
  2. The applied NIC aliases changes were not retained after rebooting the ESXi host

 

Resolution

To resolve this issue perform the following:

  1. Log into the DCUI of the ESXi host using root credentials.
  2. Go to Troubleshooting Options > select Enable ESX Shell > hit enter to either enable.
  3. Press ALT F1 to gain access to the Shell.
  4. Log in again with root credentials. 
  5. Verify that the NICs have the correct alias information by running the command localcli --plugin-dir /usr/lib/vmware/esxcli/int/ deviceInternal alias list to verify the PCI or logical identifiers (this can be confirmed by looking at the physical switches NICs MAC).
  6. Run the command esxtop > hit enter > press the letter n to view the networking view and review which NIC is in use by the ESXi hosts management vmkernel adapter. See the example output below, where the management vmkernel adapter is vmk0 and is using vmnic0:
  7. If the NIC currently in use is not a NIC that can pass the management traffic, only proceed with the process below if the ESXi host has access to multiple NICs. If not, please open a case with your physical network vendor as the issue is not with the host at this point, its with the physical NIC.
  8. To proceed if there are multiple NICs, bring the NIC temporarily down by running the command esxcli network nic down -n vminc#.
  9. After the NIC is down, verify if the ESXi hosts networking comes back online by pinging the host or looking in vCenter to see if the ESXi host shows as responsive and up. 

If the process above does not resolve the issue, please open a case with VMware by Broadcom support.