vCenter VAMI file based backup is failing to start
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vCenter VAMI file based backup is failing to start

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Article ID: 412364

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • The size metrics for the backup process all show 0
  • The backup process is stuck at 0% and does not progress
  • The process eventually times out with the error: “The RESTORE job with pid ##### does not exist anymore”
  • When investigating /var/log/vmware/applmgmt/backup.log, there are no updates or entries for the backup process.
  • The /var/log/vmware/applmgmt/applmgmt.log file has entries similar to the logs below:

YYYY-MM-DDTHH:MM:SS PM PDT [9853]INFO:backupRestoreAPI:Command "['/usr/bin/python', '/usr/lib/applmgmt/backup_restore/py/vmware/appliance/backup_restore/BackupManager.py', '--cleanup']" return ###-#### exit status 1.''stdout=''stderr='  File "/usr/lib/applmgmt/backup_restore/py/vmware/appliance/backup_restore/BackupManager.py", line 202
    if netAddr in addressLst:
IndentationError: unexpected indent
'YYYY-MM-DDTHH:MM:SS PM PDT [9853]ERROR:backupRestoreAPI:Failed to clean up the previous backup job files at remote location. Cleanup the backup files manually.

Environment

  • 8.x

Cause

An edit or change to the BackupManager.py python script is preventing the backup process from initiating.

In the example shown in the Issue/Introduction, there is an indent at line 202 causing the error.

Resolution

Please engage Broadcom support to assist in restoring the file to its original format.