RU9 Upgrade Fails on Linux with "Could not resolve host: ent-shasta-rrs.symantec.com; Name or service not known"
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RU9 Upgrade Fails on Linux with "Could not resolve host: ent-shasta-rrs.symantec.com; Name or service not known"

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Article ID: 412342

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Updated On:

Products

Endpoint Protection

Issue/Introduction

During a RU9 upgrade on Symantec Endpoint Protection (SEP) for Linux, some users may encounter a failure with the error:

Could not resolve host: ent-shasta-rrs.symantec.com; Name or service not known

Environment

SEP 14.3 RU9 Linux Agent

Cause

Running the upgrade command: installagent.sh --update-kmod produced errors indicating the Linux SEP repository was inaccessible:
curl#6 - "Could not resolve host: ent-shasta-rrs.symantec.com; Name or service not known"

Lux logs confirmed that the proxy configuration appeared correct:

Protocol: HTTP
Host: XX.XX.XX.XX
Port: XXXX

The cafconfig.ini file also contained valid proxy settings:

[proxy-config]
proxy-mode=Manual
proxy-uri=http://XX.XX.XX.XX:XX
proxy-username=%PROXY_USERNAME%
proxy-password=%PROXY_PASSWORD%
proxy-host=XX.XX.XX.XX
proxy-port=XXXX
proxy-https-port=XXXX

Running curl -vv  to either URLs with the proxy environment variable successfully accessed the repository:
< HTTP/1.1 200 Connection established.

https://linux-repo.us.securitycloud.symantec.com/SAL/1.4/rhel9/x86_64/repodata/repomd.xml
https://ent-shasta-rrs.symantec.com/linuxrepo/SAL/1.4/rhel9/x86_64/repodata/repomd.xml


Resolution

To temporary resolve the issue Add the proxy configuration directly to /etc/yum.conf as follows:

proxy=http://XX.XX.XX.XX:XXXX
proxy_username=%PROXY_USERNAME%
proxy_password=%PROXY_PASSWORD%

After re-run the RU9 installer.

A permanent fix to the RU9 package will be applied in the next release of the of the SEP Linux Agent, available in Q4 2025 - Q1 2025.