Unable to deploy TKG MGMT cluster in TCA-CP
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Unable to deploy TKG MGMT cluster in TCA-CP

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Article ID: 412327

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Updated On:

Products

VMware Telco Cloud Automation

Issue/Introduction

- Unable to deploy TKG MGMT cluster on the TCA-CP
- Found below errors on the logs, captured from TCA-CP CLI
"Failed to invoke API on cluster : Get " https://XX.XX.XX.XX:6443/version?timeout=32s": dial tcp XX.XX.XX.XX:6443: connect: connection refused, retrying"
"[Err-controller] : error getting cluster client using its kubeconfig, err: [Get " https://XX.XX.XX.XX:6443/version?timeout=32s": dial tcp XX.XX.XX.XX:6443 connect: connection refused]"



Environment

2.3
3.2

Cause

Connectivity issues to the bootstrap VM from TCA-CP & Airgap Appliance

Resolution

- Validate IP, DNS Information & Gateway IP and Segment Configuration (MTU) for the TCA-M,TCA-CP & Bootstrap VM
- Validate the ports and protocols are allowed on the underlying physical infrastructure firewall as the mentioned in the Ports and Protocols for the TCA page

Additional Information

Reference Documents
Ports and Protocols for the TCA
Requirements page for Deploy a Management Cluster

Please reach out to Broadcom Support if the above resolution steps didn't fix the issue.