Multiple Plugins on the vCenter report Failed State
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Multiple Plugins on the vCenter report Failed State

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Article ID: 412244

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Multiple in-house plugins (VMware vCenter Lifecycle Manager, VMware vSphere Lifecycle Manager Client, etc.) and third-party vendors (Cisco UCS Manager, OpenManager, etc.) reported the FAILED state. 

Environment

VMware vCenter Server 

Cause

Service registrations on a vCenter Server are critical because they allow client plugins to discover and access services provided by the vCenter instance. In cases when the service registrations are corrupted due to errors, misconfigurations, or network issues, client plugins will be unable to find the necessary services on the vCenter, leading to their failure to load or operate properly within the vSphere Client. 

Resolution

Ensure you have taken proper snapshots of your SSO domain. In case the vCenter is in linked mode, you must shut down all VCs that are in the SSO domain at the same time, then snapshot them, and power them on again. If you need to revert to one of these snapshots, shut all the nodes down, and revert all nodes to the snapshot. Failure to perform these steps will lead to replication problems across the PSC databases. If it is a standalone vCenter, take a powered-on no-memory snapshot. 

1. Rebuild the service registrations on the affected vCenter using the lsdoctor.py -r option. Steps have been highlighted in the KB - Using the 'lsdoctor' Tool
2. Restart services on all the vCenters in the linked mode.