vSAN disk group missing from Disk management
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vSAN disk group missing from Disk management

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Article ID: 412188

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Updated On:

Products

VMware vSAN

Issue/Introduction

  • In vCenter UI, Cluster > Configure > vSAN > Disk management may not show an existing disk group.
     



  • Host CLI, also shows the disk groups are missing while running 'vdq -i'  command..

    [root@esxi01:~] vdq -i
    [
    ]
    [root@esxi01:~] 

  • When initiating command esxcfg-scsidevs -c, you only see the boot device but no cache or capacity disks.
  • When checking the var/log/boot.gz file, there is no mention of any cache/capacity disks being loaded up during boot of the ESXi host in the logs. 
  • This issue might cause the Virtual machines to go inaccessible.

Environment

VMware vSAN 8.x

VMware vSAN 9.x

Cause

This is caused if all the disks which are part of the disk group become offline or missing from the server hardware.

Below figure shows the disks showing Standby Offline from HPE iLO console.

 

Resolution

Engage the hardware vendor to fix the disks showing Offline.
Disk group will come back online once the same disks are back online.