Error: "Unable to connect to Veeam backup infrastructure: please contact your service provider." when accessing the Veeam plugin in VMware Cloud Director
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Error: "Unable to connect to Veeam backup infrastructure: please contact your service provider." when accessing the Veeam plugin in VMware Cloud Director

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Article ID: 412126

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • The Veeam plugin installed in VMware Cloud Director (VCD) is not accessible via the tenant portal over the internet and fails with the following error:

  • When accessing the Veeam plugin, logs from the browser UI (Settings > Developer Tools > Network) show CORS (Cross-Origin Resource Sharing) errors, indicating that requests to the Veeam URL are blocked due to cross-origin policy restrictions:
    Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://veean_url:port_number/vCLoud/whitehats/api/Login/LoginwithToken. (Reason: CORS request did not succeed). Status code: (null).

Environment

VMware Cloud Director 10.x

Cause

VMware Cloud Director enforces CORS only for its own domains (such as the VCD IP, FQDN, or public URLs). It does not manage or enforce CORS settings for third-party integrations like Veeam. As a result, cross-origin requests to the Veeam URL will be blocked when accessed via the tenant portal using internet.

Resolution

1.Verify Network Connectivity:

From each VCD cell, run the following command to ensure that the VCD environment can reach the Veeam server on the required port (typically 9443):

curl -v telnet://<veeam_url>:9443

2. Confirm Veeam Server Accessibility:

Ensure that the Veeam server is accepting remote connections on port 9443 by following the steps mentioned in the documentation.

3. If connectivity is confirmed and the issue still persists, contact the Veeam support team for further investigation: Veeam_support