Internal Error when testing Google Chat Webhook
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Internal Error when testing Google Chat Webhook

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Article ID: 411951

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Updated On:

Products

CloudHealth

Issue/Introduction

When configuring a Google Chat Webhook integration in CloudHealth, the test step is returning an internal error

Cause

This is caused because the Google Chat webhook endpoint expects a different format than the default template that is auto populated in the setup dialog

Resolution

Replace the template with the following:

{ "text" : "{ Message: {{{ message }}}, PolicyName: {{{ policyName }}}, PolicyBlockName: {{{ policyBlockName }}}, AlertLink: {{{ alertLink }}}, EvaluatedAt: {{{ evaluatedAt }}}, IntegrationName: {{{ integrationName }}}, ResourceType: {{{ resourceType }}}, ResultSummary: {{{ resultSummary }}},  Violations: {{#violations}}{ New: {{New?}}, AccountName: {{AccountName}}, Tags: {{Tags}} } {{/violations}} }"} 

The template can then be further customized as needed.