NSX Upgrade Fails on Edge Node After Users Were Created Locally From Edge Node CLI
search cancel

NSX Upgrade Fails on Edge Node After Users Were Created Locally From Edge Node CLI

book

Article ID: 411831

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

  • Using Root credentials, users were added locally to an NSX Edge node. 
  • NSX Upgrade is failing on the node where users were locally created. 
  • Upgrade-coordinator.log on the NSX Managers and syslog.log on the Edge node has the following error: 
CommandFailedError: Command ['/bin/sed', '-i', '-r', 's/:$/:/?/g', '/os_bak/etc/group'] returned non-zero code 1: b"/bin/sed: -e expression #1, char 8: unknown option to `s'\n"

Environment

VMware NSX

Cause

Creating users locally on an Edge node is not supported. The only supported method to create users in NSX is through the Manager UI. 

See: Add a Local User

Resolution

  • Do not reboot the affected Edge node
  • Open a support request through the Broadcom Portal if you have added a user locally to an Edge node from the CLI and encounter this issue.